Service esc

Faults and Technical chat for the Vauxhall Astra K
Wba_kol
Posts: 2
Joined: Mon Sep 04, 2017 11:02 pm
Astra Model: 1.4 turbo sri 150
Astra Options: Two tone 18" alloys
Astra Colour: Flip chip silver
Location: Redditch

Re: Service esc

Post by Wba_kol » Wed Mar 07, 2018 6:20 pm

I’ve been getting esc service come up on mine ....I have car genie from the AA and it was telling me it was a battery problem .Vauxhall confirmed this and replaced battery and was covered under warranty and to date no probs at all.


Fizzydrink
Posts: 44
Joined: Tue Jan 31, 2017 7:48 pm
Astra Model: Astra k 1.4T Sri
Astra Colour: Black
Location: Scotland

Re: Service esc

Post by Fizzydrink » Wed Mar 07, 2018 8:50 pm

Thanks for that good info. Mines booked in for next Thursday so hope it’s something quite simple
1.4T SRI Carbon Flash


Astraknot
Posts: 5
Joined: Sat Jan 13, 2018 3:07 pm
Astra Model: Tech Line 1.4T 125
Astra Colour: White

Re: Service esc

Post by Astraknot » Fri Mar 09, 2018 7:18 pm

Hi,

Mine came on for a few seconds for the first time this morning. The car seems to be fine. I have a 2017 version which according to people in the forum have an updated engine, meaning the piston problem has been fixed. Also, the car took a little longer to start than usual then the service esc came on for a few seconds.


Ivanzu
Posts: 1119
Joined: Fri Feb 03, 2017 10:50 am
Astra Model: 1.4T
Astra Colour: Power Red

Re: Service esc

Post by Ivanzu » Fri Mar 09, 2018 10:35 pm

Service ESC doesnt mean engine problem all the time.


ArcanumFox
Posts: 145
Joined: Wed Nov 25, 2015 12:18 am

Re: Service esc

Post by ArcanumFox » Fri Mar 09, 2018 11:48 pm

Hi all,

So 'Service ESC' stands for 'Service/Repair Electronic Stability Control'. It's telling you there is a fault with the Electronic Stability Control. It's a vehicle module monitored issue that tracks whether a problem with the car is potentially causing an issue with the car skidding on ice/water. It will trigger in normal conditions if there is a fault with the engine resulting in a loss of power or torque. 9 times out of 10 it's the ignition coil in a petrol engine but with the turbocharged Astra's a larger proportion of issues relate to piston failure due to Low Speed Pre-Ignition.

Book in at a dealer if you have ever had this on the dashboard.


Astraknot
Posts: 5
Joined: Sat Jan 13, 2018 3:07 pm
Astra Model: Tech Line 1.4T 125
Astra Colour: White

Re: Service esc

Post by Astraknot » Sat Mar 10, 2018 2:10 pm

Hi,

There are no lights on while driving, its just on the start up for like a second then it disappeared yesterday morning. Do you think i should book this in?

Thanks.


Ivanzu
Posts: 1119
Joined: Fri Feb 03, 2017 10:50 am
Astra Model: 1.4T
Astra Colour: Power Red

Re: Service esc

Post by Ivanzu » Sat Mar 10, 2018 9:52 pm

Yes


Fizzydrink
Posts: 44
Joined: Tue Jan 31, 2017 7:48 pm
Astra Model: Astra k 1.4T Sri
Astra Colour: Black
Location: Scotland

Re: Service esc

Post by Fizzydrink » Fri Mar 16, 2018 2:46 pm

Just got mine back and as mentioned by wba- kol it was the battery that was almost flat?. Strange one that!. Anyway they have charged it up and I'll see how it goes. If it happens again I'll be demanding a new battery.
Thanks for all your help guys much appreciated
1.4T SRI Carbon Flash


Astraknot
Posts: 5
Joined: Sat Jan 13, 2018 3:07 pm
Astra Model: Tech Line 1.4T 125
Astra Colour: White

Re: Service esc

Post by Astraknot » Sun Mar 18, 2018 2:38 pm

Hi,

Thanks for the update, my guess was the battery as well.. mine is booked in for tommorow ill make sure to tell them about the battery!


Fizzydrink
Posts: 44
Joined: Tue Jan 31, 2017 7:48 pm
Astra Model: Astra k 1.4T Sri
Astra Colour: Black
Location: Scotland

Re: Service esc

Post by Fizzydrink » Fri Mar 23, 2018 3:43 pm

Hi all
Had to take the car back after the battery failed again. This time they have changed the battery and re- programmed the BCM. Really praying that’s this issue sorted now?. This car is becoming very unreliable as I’ve had to have quite a few things fixed on it now.
1.4T SRI Carbon Flash


Post Reply

Return to “Faults & Technical”