Aftermarket android head unit installation

All Vauxhall Astra K related discussions
Post Reply
Alekias
Posts: 1
Joined: Sat Jun 27, 2020 5:03 pm

Aftermarket android head unit installation

Post by Alekias » Sat Jun 27, 2020 5:19 pm

Hi all,

I'm new to the forum, even if I've looked to some topic about various things in the past and I must say I've always found very good information about what I was looking for!
Since my Intellilink touch screen died and the cost for replacement was really high I decided to consider to install an aftermarket chinese android unit (Klyde https://www.alibaba.com/product-detail/ ... 2fcaVbgkt7).
The unit should have been plug and play, but I found out it is not, the cable they sent me is completely wrongly cabled and also caused the blown of a fuse when I plugged it as they suggested.
I now have the dash completely disassembled and I'm trying to figure out how to fix the situation, but I cannot find any wiring diagram of the infotainment Delphi siver-box connections (p/n 28493719).
I saw on the forum some information about the speakers connections (green connector that I called A in the picture below), but I couldn't fine anywhere information about the other wires (connectors B and C)

Cattura.JPG

I was hoping someone here that has had my same problem could help with that!
I've also made an excel table to better describe how the wires look like.

Cattura 2.JPG

I thank in advance everyone that will look into that!

Baich
Posts: 39
Joined: Fri Nov 16, 2018 7:29 pm

Re: Aftermarket android head unit installation

Post by Baich » Thu Aug 13, 2020 9:36 pm

Hi
I use this brand klyde. In my opinion it's very bad product

Luks
Posts: 2
Joined: Fri Dec 25, 2020 4:06 pm

Re: Aftermarket android head unit installation

Post by Luks » Fri Dec 25, 2020 4:07 pm

Hi, did you sorted? I bought same head unit and don't have idea how to plug in?

CondeGil
Posts: 1
Joined: Sun Mar 28, 2021 11:02 am

Re: Aftermarket android head unit installation

Post by CondeGil » Sun Mar 28, 2021 11:12 am

I've just installed a head unit in my Astra, but mine came with a cable for this model (I have a teyes cc3 head unit). Every thing works just fine. Only had two minor issues. The 4 turning lights button didn't work and I had no sound what so ever for the "small speaker" (turning lights sounds, parking sensors, and seatbelt warning). The first issue I was able to fix properly (I've was able to figure out the proper 3 wires that make the button to work in the cable behind the old head unit screen). Regarding the small speaker I didn't found the proper cables so I throw out another small speaker behind the new head unit and it's working ok. I'm almost certain that one of the connection in your "D" schematics are for that speaker. But I didn't found it

20210327_120527.jpg

That's my test for the 4 turning lights button.

Post Reply