Two months old Astra K, starting issue

Faults and Technical chat for the Vauxhall Astra K
Post Reply
ukilci
Posts: 2
Joined: Thu Nov 19, 2020 5:03 am

Two months old Astra K, starting issue

Post by ukilci » Thu Nov 19, 2020 5:41 am

Hi everyone, I bought a new Astra (2020) two months ago. It has 1.2 liter turbo petrol engine and a manual gearbox. I was very pleased with the car until two days ago when I cannot start the engine in the parking lot. I called the Opel (I'm located in Turkey btw) assist and my car was towed to the service. They told me the fault seems to be related to crankshaft sensor (one of the error codes was P0335). They removed the battery, waited like 20 minutes and then plugged it back. Car started normally. They suggested me to leave the car for the day so that they would check the connections, wiring and investigate more adding that they had never seen this fault in a new car. So I left the car. The next day, I was called and told that the car was ready. They could not find any hardware issues, said the sensors and wiring were OK, removed the fault and recalibrated the car.
I am myself an engineer and I am not satisfied with this because it seemed they just ignored the fault than solving it. I told this and they assured me that the fault will unlikely to reoccur. What I am wondering is that, did you guys experience something like this? Does removing/replugging the battery approach really solves anything?

astraowner
Posts: 1645
Joined: Sun Dec 02, 2018 8:54 am
Astra Model: 2016 Astra K 1.6 110HP
Astra Options: Lane assist, dual zone Climate Control.
Astra Colour: Asteroid Grey

Re: Two months old Astra K, starting issue

Post by astraowner » Thu Nov 19, 2020 3:15 pm

Nowadays cars are "computers" so "restarting" it sometimes does get rid of problems.

Please remember that as long as the battery is connected the modules never really do a "Cold boot" so the only option is to disconnect the battery for this.

If this really solved the problem or you have an intermittent problem i can not say, but i can say that diagnosing a periodic fault that is not there when diagnosing is really really hard to do.
2016 Astra K 110HP, Opel Eye camera, front and rear parking sensors, dual zone climate control and heated front seats, sight and light pack.

ukilci
Posts: 2
Joined: Thu Nov 19, 2020 5:03 am

Re: Two months old Astra K, starting issue

Post by ukilci » Sat Nov 21, 2020 10:38 am

I got the car back the other day. I have been using it regularly to go to work, no problem so far. I hope it will never happen again. If it does though, I'll update here so that others would know what to do in a similar situation.
Ironically, my decision to buy a new car in the first place, was to get away from possible problems that I might experinece in a used one.

Pompeydave
Posts: 696
Joined: Sun May 21, 2017 2:42 pm
Astra Model: Astra Sri nav VX-line 1.6t
Astra Colour: Silver

Re: Two months old Astra K, starting issue

Post by Pompeydave » Sat Nov 21, 2020 11:31 am

Hopefully fault won't reoccur but annoying as car only a couple of months old. Really need to know what triggered the sensor in the 1st place...could it be water getting onto it ? Chances are it will happen again if a faulty sensor. But as astraowner said trying to diagnose it will be a pain but for your own satisfaction I hope garage change the sensor next time under warranty.

Post Reply