Infotainment - Corrupt & flashing screen

Faults and Technical chat for the Vauxhall Astra K
Post Reply
CharlieMike
Posts: 128
Joined: Mon Jun 05, 2017 12:09 pm

Infotainment - Corrupt & flashing screen

Post by CharlieMike » Tue Apr 16, 2019 10:34 am

Over the last few days my infotainment has been playing up.

when I start the car the screen is corrupt and flashing, although the buttons seems to work.
After what could be a few seconds or many minutes it usually sorts itself out.




has anybody else had this issue?


(66 plate, Astra K, 1.4 150bhp)


Sammijanelewis
Posts: 3
Joined: Sat Apr 13, 2019 10:04 pm

Re: Infotainment - Corrupt & flashing screen

Post by Sammijanelewis » Tue Apr 16, 2019 5:17 pm

We had the exact same issue with ours end of last yr, also 66 plate Astra SRI Turbo nav. Ended up having to have new infotainment screen, covered under warranty. I would take it to the garage.
Sam


CharlieMike
Posts: 128
Joined: Mon Jun 05, 2017 12:09 pm

Re: Infotainment - Corrupt & flashing screen

Post by CharlieMike » Wed Apr 17, 2019 9:04 am

In a way it's good see that somebody has had the issue and that it was resolved easily enough. Mine is booked in but because they couldn't provide a courtesy car sooner, it's going to be 10th May. I say courtesy car, but actually they don't have any cars so it's going to be a transit van.


NathanG1993
Posts: 2
Joined: Tue Apr 23, 2019 3:48 pm

Re: Infotainment - Corrupt & flashing screen

Post by NathanG1993 » Tue Apr 23, 2019 3:53 pm

Hi Mate, Just asking about this as my car is currently having the exact same issue and has been going on for a while now. Currently have a 66 Astra SRI nav 1.4t, originally took it to a vauxhall dealer 2 weeks ago who told me it was due to an update on the infotainment system that was causing it too glitch out. Low and behold, they had the car for 4hrs and when I went to collect it after they said they fixed it, it did it again and looked to have not done much to the car bar the recall updates

Did you request the screen to be replaced? Or is it an electrical issue on the car? Got it booked it to go again on 29th April and they don’t seem clued up as to what is causing the screen to go haywire so would be handy on what to say is causing the fault, Cheers

Cheers


NathanG1993
Posts: 2
Joined: Tue Apr 23, 2019 3:48 pm

Re: Infotainment - Corrupt & flashing screen

Post by NathanG1993 » Wed Apr 24, 2019 1:31 pm

NathanG1993 wrote:
Tue Apr 23, 2019 3:53 pm
Hi Mate, Just asking about this as my car is currently having the exact same issue and has been going on for a while now. Currently have a 66 Astra SRI nav 1.4t, originally took it to a vauxhall dealer 2 weeks ago who told me it was due to an update on the infotainment system that was causing it too glitch out. Low and behold, they had the car for 4hrs and when I went to collect it after they said they fixed it, it did it again and looked to have not done much to the car bar the recall updates

Did you request the screen to be replaced? Or is it an electrical issue on the car? Got it booked it to go again on 29th April and they don’t seem clued up as to what is causing the screen to go haywire so would be handy on what to say is causing the fault, Cheers


CharlieMike
Posts: 128
Joined: Mon Jun 05, 2017 12:09 pm

Re: Infotainment - Corrupt & flashing screen

Post by CharlieMike » Wed May 08, 2019 11:01 am

Hi Nathan,

Sorry I haven't been replied - been away from the site for a while.

Mine is also a 66 Astra SRI nav 1.4t and I'm still waiting for the car to be looked at!!!

I need a courtesy car and the soonest they could give me one is 16th May(!) so I'll have to post an update once they've seen it.

The issue is still present and happens every time I get into the car. Sometimes the screen is completely blank.

As there are at least 3 of us here with the same model and year I wonder whether this is a known issue. That should make it much easier to reach a speedy resolution. I'll certainly be mentioning it to the dealer when the car's dropped off.

I'm surprised they would suggest this is a software issue but then they're only the techs, what do they know? ;)

My guess is it's a hardware issue related to the display driver itself and that's why they should just swap it out straight away.


How did you get on when yours went in on 29th April? Did they fix it?


CharlieMike
Posts: 128
Joined: Mon Jun 05, 2017 12:09 pm

Re: Infotainment - Corrupt & flashing screen

Post by CharlieMike » Mon May 20, 2019 2:58 pm

So I got my car back from the dealer on 16th May and they just replaced the "whole unit" straight away rather than just the screen and it's all working fine now.

I used quotes around "whole unit" because that's what I was told but I'm not quite sure what the guy really meant by that. I expected a system set to factory default settings when I got in the car but it seemed to be configured the same as my previous one. Maybe they did transfer the configuration as well as part of the process, but i'd be very surprised if they do that.

Anyway it was a good result overall.

I expected to have to take the car back at a later date but they must have had the part in stock in order to do it so quickly.


astraowner
Posts: 733
Joined: Sun Dec 02, 2018 8:54 am
Astra Model: 2016 Astra K 1.6 110HP
Astra Options: Lane assist, dual zone Climate Control.
Astra Colour: Asteroid Grey

Re: Infotainment - Corrupt & flashing screen

Post by astraowner » Mon May 20, 2019 7:00 pm

In the service menu of the R4.0 atleast, you can download the radio configuration to a USB stick.

Maybe this was done and then put back on the new HMI as a service.

No matter what, if they changed something and it's working now, you should not complain :)
2016 Astra K 110HP, Opel Eye camera, front and rear parking sensors, dual zone climate control and heated front seats, sight and light pack.


Post Reply

Return to “Faults & Technical”