Vauxhall Astra K Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi I recently purchased a 2016 (66) 1.4 Turbo SRI model back in 2021 November, after having the car for a bit as colder temperatures approached upon starting the car it would take a little longer to start as per normal and would sometimes emit the “Service ESC” message, upon clearing it nothing would show up. On days where the temperature is warmer I would find the car doesn’t have these messages pop up.
Yesterday as I was driving the service ESC message had pop up as well as abs light and a message to say forward collision prep unavailable. I’ve read some bad things about lspi problems, misfiring and Vauxhall not being very customer friendly with these situations, I’m only 20 and I’m not sure if my vehicle is in warranty so I thought the best place to start for help would be here where I was reading all this information.
What should be my approach to this? I was thinking new coil packs/ spark plugs/ battery and oil but im not sure if it will fix the issue?
 

·
Registered
Joined
·
288 Posts
I would agree with Redman,judging by previous threads with the same issue it does sound like either your battery is on the way out or needs charging .Have you been doing a lot of short journeys?
 

·
Registered
Joined
·
1,468 Posts
Go and get your battery load tested, most decent independent garages would test it for you for free.
I've had batteries last for as little as 18 months, sometimes over 10 years for no specific reason.
Although if it's a start and stop battery and it needs replacing they cost a bit more.
 

·
Registered
Joined
·
1,009 Posts
Yep i agree,battery is the first thing to check,
as you're only 20 and if you intend doing any of your own diagnostics then i would recommend investing in a decent obd2 reader,a volt meter and maybe a battery charger.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
Guys thank you so much for your help and suggestions, I’ll have the battery checked asap, I’m due to get it diagnosed and checked on Monday by a very trust worthy family mechanic of mine.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
I would agree with Redman,judging by previous threads with the same issue it does sound like either your battery is on the way out or needs charging .Have you been doing a lot of short journeys?
I have been doing some short journeys and some long journeys, never experienced anything as I’m driving until recently today/yesterday, it’s just the abs light and ESC message but upon turning off the engine and starting again everything clears.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #8 ·
Also another message from me, any chance that I may be able to get some links to the other forums (still currently looking) to help my peace of mind :)
 
1 - 8 of 8 Posts
Top