Vauxhall Astra K Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi

My original Intellilink R4.0 system died went off blank screen never came back on. Had been going on and off for weeks.

Anyway i bought a new system plugged it into my vehicle and im getting the same outcome. I understand the new unit needs programming to my vehicle but to my understanding the new system should now be saying locked when plugged into my vehicle.

I have checked the fuses they are all working just wondered if anyone knew what it could be
Thanks in advance
 

·
Registered
Joined
·
1,710 Posts
Hi
The problem may be your HMI module (human machine interface) has given up the ghost. Have read about it happening a few times on the R4.0 system. The screens are plug and play iirc.
Get in touch with intelilinkmods who will advise you more. The HMI module on the R4.0 is to the right of the drivers footwell I believe. Are you referring to the screen as the system or the HMI module?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #3 ·
Hi
The problem may be your HMI module (human machine interface) has given up the ghost. Have read about it happening a few times on the R4.0 system. The screens are plug and play iirc.
Get in touch with intelilinkmods who will advise you more. The HMI module on the R4.0 is to the right of the drivers footwear I believe. Are you referring to the screen as the system or the HMI module?
Not sure to be honest all i know is the screen kept working intermittently and eventually failed.

I spoke to intellimods and they said it was s failed unit it would need replacing. The Bluetooth was still connecting to my phone before i took it out. Just nothing on screen and the buttons didnt work

Bought the new unit plugged it in and same outcome nothing on screen. Its being programmed to my vehicle later today but not hopeful of it working

Thanks

Kirsty
 

·
Registered
Joined
·
1,710 Posts
Hopefully he will get it sorted for you, let us know how you get on.
If all else fails I think intelilinkmods can program the HMI if you send it to them. You may have to send them your existing one aswell as your replacement, check with them first as I maybe wrong. Good luck.
 
1 - 7 of 7 Posts
Top